Concrete5 Submission Requirements

Refer to the following guidelines before submitting your Concrete5 Theme.

The minimum version requirement for Concrete5 is:

  • Version 5.5

Submission Requirements

  • Follow the Concrete5 Coding Style Guidelines found here.
  • Follow the Concrete5 Theme Development best practices. This will ensure the following:
    -  Themes install without error(s).
    -  Concrete5 Add-ons work with the theme and other add-ons.
    -  Your customers will have a pleasant user experience.
  • Themes will be required to use, and work flawlessly, with whichever version of jQuery ships with that version of Concrete5.

Documentation Requirements

Written documentation is required to help buyers with installation and setup.

  • The full installation process of the theme must be documented.
  • All required add-ons must be documented in your item description and documentation file.
  • Custom features falling outside Concrete5's core functionality must be clearly documented.
2 votes
This article was helpful
This article was not helpful
Help Desk Software by Kayako Resolve