Ubercart Submission Requirements

Refer to the following guidelines before submitting your Ubercart theme.

The minimum versions required for Ubercart are:

  • Drupal 7.x
  • Ubercart 3

Technical Requirements

  • Follow the Drupal coding standards found here.
  • Follow the Ubercart best practices.
  • Templates must work properly with digital and physical goods as well as product packs or bundles.
  • Styling must work properly on configurable, discounted, and out-of-stock items.
  • Styling must work properly on currencies which usually have high numbers ($200US =16236.00Yen).
  • Template must handle large descriptions and images without "breaking" the design.
  • Breadcrumbs must function properly with hierarchies at least three levels deep.

Documentation Requirements

Written documentation is required to help buyers with installation and setup.

  • The full installation process of the theme must be documented.
  • All required modules must be documented in your item description and documentation file.
  • Custom features falling outside Drupal and Ubercart's core functionality must be clearly documented.
  • All required and custom plugins (eg. jQuery) must be documented in your item description and documentation file.
1 votes
This article was helpful
This article was not helpful
Help Desk Software by Kayako Resolve